VMware vCenter Appliance Migration auf Version 6.5 schlägt fehl

Admin-Tipps | Posted by SYMPLASSON | 20 September 2018
VMware vCenter Appliance Migration auf Version 6.5 schlägt fehl


Hintergrund:

Es soll eine bestehende VMware vCenter Appliance Version 5.5 auf Version 6.5 upgegraded werden.

Dafür wird das vCenter Server Appliance Migration Tool (VCSA 6.5 Installer ISO) von der VMware Webseite heruntergeladen und die Installation damit gestartet. Entsprechende Anleitungen finden sich an anderer Stelle im Internet, daher wird hier nicht weiter darauf eingegangen.

 

Die Fehlermeldung:

Encountered an internal error. See /var/log/firstboot/vpostgres-firstboot.py_xxxx_stderr.log

Leider enthält die  Logdatei selber keine hilfreichen Inhalte:

Upgrade import step failed
vPostgres firstboot (action=firstboot) failed

Wir haben etwas in einschlägigen Foren im Internet recherchiert, diese aber verweisen nur auf DNS-Probleme, Zeitprobleme, Größenprobleme der Zielfestplatten der neuen vCenter Appliance, usw. hin.

Nichts davon ist jedoch in diesem Fall die Ursache des Problems gewesen.

 

Die Auslöser:

Die Auslöser waren fehlerhafte Einträge in der PostgresSQL Log-Datenbank der Quell-vCenter-Appliance (event/history)!

Und obwohl beim Update-Prozess nur die Konfiguration für die Übernahme ausgewählt war, scheint das System doch Teile der Logs-Einträge des alten Appliance auszulesen.

 

Die Lösung:

Geholfen hat in diesem Fall das Abschneiden aller historischen Daten auf 0 Tage:

Anmelden an der alten vCenter Appliance 5.5 mit SSH (z.B. via Putty).

Aufrufen der Shell

  1. Sie benötigen das Kennwort der Datenbank. Dieses erhalten Sie mit
    cat /etc/vmware-vpx/embedded_db.cfg | grep PASSWORD

  2. Im nächsten Schritt verbinden Sie sich mit der Postgres DB:
    /opt/vmware/vpostgres/1.0/bin/psql -d VCDB vc

    (hier wird das oben per Grep gefundene Kennwort benötigt)

  3. Die Logdateien schneiden Sie dann ab:
    TRUNCATE TABLE vpx_event CASCADE;


Anschließend lässt sich die Konvertierung auf vSphere vCenter 6.5 problemlos durchführen.

______________________________________________________________________________________________________________ 

Ähnliche Artikel:

VMWare vCenter Appliance Migration auf Version 6.5 schlägt fehl (1)