VMWare vCenter Appliance Migration auf Version 6.5 schlägt fehl

Admin-Tipps | Posted by SYMPLASSON | 09 Februar 2018
VMWare vCenter Appliance Migration auf Version 6.5 schlägt fehl

 

Der Fehler 

Error: 
Entcountered an internal error. See /var/log/firstboot/vpostgres-firstboot.py_8001_stderr.log

Resolution: 
This is an unrecoverable error, please retry install. If you run into this error again, please collect a support bundle and open a support request

 

Hintergrund

Es soll eine bestehende VMware vCenter Appliance Version 5.5 auf Version 6.5 upgegraded werden.

Dafür wird das vCenter Server Appliance Migration Tool (VCSA 6.5 Installer ISO) von der VMware Webseite heruntergeladen und die Installation damit gestartet.

Entsprechende Anleitungen finden Sie an anderer Stelle im Internet, daher wird hier nicht weiter darauf eingegangen.

 

Die Installation läuft bis kurz vor Ende fehlerfrei:

Neue virtuelle Instanz wurde korrekt installiert, Daten werden sauber auf die neue Instanz kopiert:



Im nächsten Schritt startet allerdings die Postgres SQL-Datenbank nicht und läuft auf den oben beschriebenen Fehler:

--> Entcountered an internal error. See /var/log/firstboot/vpostgres-firstboot.py_8001_stderr.log

 

Im Postgres-firstboot-Log findet sich nichts Brauchbares:

 2018-01-25T14:31:02.061Z   Upgrade import step failed

2018-01-25T14:31:02.061Z   vPostgres firstboot(action=firstboot) failed

 

Verursacher

In diesem Fall lag die Ursache des Problems in den installierten Plugins des vCenters. Dort das HP OneView Plugin for VMware vCenter installiert.

Nach der Installation des Plugins läuft die Installation fehlerfrei!

 

Plugin entfernen

Folgendermaßen lässt sich das Plugin entfernen:

Durch starten des Managed Object Browsers  über https://vcenter.domain.local/mob erreicht man folgendes Fenster:

 

Dort wird die Beschreibung des entsprechenden Plugins (ohne die Anführungszeichen) in die Zwischenablage kopiert (in unserem Fall com.hp.ov4c.ngc.all.v5.5)

…und über den Aufruf „UnregisterExtension“ entfernt:

Anschließend lässt sich die Konvertierung auf vSphere vCenter 6.5 problemlos durchführen.

 ______________________________________________________________________________________________

Ähnliche Artikel:

VMWare vCenter Appliance Migration auf Version 6.5 schlägt fehl (2)